SocialPM download link failed: HTTP Status 404

Splash Forums PrettyFaces Users SocialPM download link failed: HTTP Status 404

This topic contains 3 replies, has 2 voices, and was last updated by  Lincoln Baxter III 11 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #17799

    xuzhike
    Participant

    Hi, lincoln,

    cannot download SocialPM WAR(UI and WS) from http://code.google.com/p/ocpsoft-tools/,

    click the link “(UI) Web-Interface WAR download” or “(WS) Web-Services WAR download”:

    HTTP Status 404 –

    whould you please help to fix it? thx

    I want to run them in my local and study

    #20294

    SocialPM is currently being migrated and the only way to get it is to check out the code an run a build. Sorry for the inconvenience!

    –Lincoln

    #20295

    xuzhike
    Participant

    Hi, Lincoln,

    Thanks for your reply.I checked the codes out and finally built them successfully there are two war files: socialpm-ws-1.0.1 and socialpm-ui-1.0.1.after deploy them to webapp in same Tomcat6.0.20, associated table and data was created in my MySQL. but when I try to access: http://localhost:8080/socialpm-ui-1.0.1/admin

    the page can be displayed,but something wrong:

    We’re sorry :( Sometimes things go wrong. Click here to return to the home page.

    there are the following error in tomcat cmd window:

    FATAL: Error Rendering View[/faces/admin.xhtml]

    javax.faces.FacesException: javax.el.ELException: /faces/admin.xhtml @19,51 disabled=”#{adminBean.databaseInitialized}”: Error reading ‘databaseInitialized’ on type com.ocpsoft.socialpm.pages.admin.AdminBean

    ……(note: skip middle error and get the last two Caused by)

    Caused by: java.lang.RuntimeException: java.net.ConnectException: Connection refused: connect

    at org.jboss.resteasy.client.core.ClientInvoker.invoke(ClientInvoker.java:109)

    at org.jboss.resteasy.client.core.ClientProxy.invoke(ClientProxy.java:59)

    at $Proxy86.login(Unknown Source)

    at com.ocpsoft.socialpm.SysServiceHolder.getClient(SysServiceHolder.java:79)

    at com.ocpsoft.socialpm.SysServiceHolder.getUserService(SysServiceHolder.java:95)

    at com.ocpsoft.socialpm.pages.admin.AdminBean.isDatabaseInitialized(AdminBean.java:76)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

    at java.lang.reflect.Method.invoke(Method.java:597)

    at javax.el.BeanELResolver.getValue(BeanELResolver.java:64)

    at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:55)

    at com.sun.faces.el.FacesCompositeELResolver.getValue(FacesCompositeELResolver.java:72)

    at org.jboss.el.parser.AstPropertySuffix.getValue(AstPropertySuffix.java:53)

    at org.jboss.el.parser.AstValue.getValue(AstValue.java:67)

    at org.jboss.el.ValueExpressionImpl.getValue(ValueExpressionImpl.java:186)

    at com.sun.faces.facelets.el.TagValueExpression.getValue(TagValueExpression.java:102)

    … 113 more

    Caused by: java.net.ConnectException: Connection refused: connect

    at java.net.PlainSocketImpl.socketConnect(Native Method)

    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)

    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)

    at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)

    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

    at java.net.Socket.connect(Socket.java:529)

    at java.net.Socket.connect(Socket.java:478)

    at …………….

    Seems there are some config file not correct, but I don’t know how to check and cannot solved it by Google.

    I just only update the following config file:

    — db.properties

    jdbc.driver=com.mysql.jdbc.Driver

    jdbc.url=jdbc:mysql://localhost:3306/socialpm

    jdbc.user=root

    jdbc.password=adminadmin

    hibernate.dialect=org.hibernate.dialect.MySQLDialect

    admin.username=admin

    admin.password=adminpass

    admin.email=noreply@ocpsoft.com

    —- ui.properties

    socialpm.services.user=admin

    socialpm.services.password=adminpass

    socialpm.services.url=http://localhost:8081/socialpm-ws

    — also I tried : socialpm.services.url=http://localhost:8081/socialpm-ws-1.0.1

    socialpm.name=SocialPM

    socialpm.blog.url=http://ocpsoft.com

    socialpm.analyticsEnabled=false

    socialpm.analyticsId=NA

    — delete the following bean config

    <bean id=”mailUtil” class=”com.ocpsoft.util.MailUtil”>

    that’s all.

    and want to know how to check socialpm-ws-1.0.1 can be accessed by other client? I try to access: http://localhost:8081/socialpm-ws and http://localhost:8081/socialpm-ws?wsdl

    and http://localhost:8081/socialpm-ws-1.0.1 and http://localhost:8081/socialpm-ws-1.0.1?wsdl

    both said:

    Cannot connect

    is there something config file I missed in my Tomcat or other problem?

    Thanks for your help

    #20296

    Try following these steps directly – http://code.google.com/p/ocpsoft-tools/#Get_Started

    I just did this myself today and it works (didn’t try with mysql, but shouldn’t be much different if you say you got the database connected and configured.)

    Make sure you go to the /admin page and click “Initalize Database” before you try to do anything else.

    –Lincoln

    Sorry for the inconvenience, this is about all the help I’ll be able to give right now, The project is going through some transitions to java ee 6 and the version in SVN is not supported right now. We should update with a message about this.

Viewing 4 posts - 1 through 4 (of 4 total)

The forum ‘PrettyFaces Users’ is closed to new topics and replies.

Comments are closed.