PrettyFilter makes JBossAS 7.1.3 hanging

Splash Forums PrettyFaces Users PrettyFilter makes JBossAS 7.1.3 hanging

This topic contains 9 replies, has 3 voices, and was last updated by  Lincoln Baxter III 9 years, 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #19108


    After upgrading from JBossAS 7.1.2 to 7.1.3 my Arquillian tests are hanging and I only see this message:

    [com.ocpsoft.pretty.PrettyFilter] PrettyFilter shutting down…

    I tried to set the log level for com.ocpsoft.pretty.PrettyFilter to ALL, but cannot see anything in JBoss’ server.log


    Hi Juergen, could you please add some more information, specified here? Thanks:


    I think a stacktrace could be helpful here. Could you please create one and post it?



    Lincoln, as mentioned above: I only see the single line and then nothing happens:

    [com.ocpsoft.pretty.PrettyFilter] PrettyFilter shutting down…

    My environment:

    * JBossAS 7.1.3 (after upgrading from 7.1.2 where the undeployment of the Arquillian tests was working fine)

    * Arquillian 1.0.3

    * JBoss Solder 3.1.1

    * Seam Persistence / Faces / International 3.1.0

    * PrettyFaces 3.3.3

    * JDK 7u9

    * Windows 7 SP1



    @Christian: Hmm, how can I create a stacktrace during undeployment after an Arquillian test run?


    Which OS are you using? And are you using an remote, embedded or managed AS7 container?


    Ah, sorry. I just saw you are using Windows 7. But what container type are you using?


    I was looking for your pretty-config.xml configuration and web.xml. But since this is already an Arquillian test case, could you upload the project here so we can run it? If not, perhaps try to reproduce this in a smaller example project that you could upload?





    Due to the message “PrettyFilter shutting down…” I was assuming that the shutdown of PrettyFaces was hanging. After switching off PrettyFaces I realized that the shutdown of the Weld service was the problem. Next I tried JBoss’ nightly build for 7.2 which uses Weld 1.1.10 (instead of 1.1.9 being used in JBoss 7.1.3) and the issue is gone.

    There was never an issue with PrettyFaces – Weld was causing the problem. Maybe you should provide a message “PrettyFaces shutdown complete” or something like that.


    Awesome! Good to know. This message is actually already being resolved in PrettyFaces 4 which is coming out shortly based on the Rewrite framework (


Viewing 10 posts - 1 through 10 (of 10 total)

The forum ‘PrettyFaces Users’ is closed to new topics and replies.

Comments are closed.