NoCLassDeffFoundError after Maven conversion

Splash Forums PrettyFaces Users NoCLassDeffFoundError after Maven conversion

This topic contains 1 reply, has 1 voice, and was last updated by  todw25 8 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #27766

    todw25
    Participant

    Hello All,

    Recently I had to convert a standard EAR JSF application that uses primefaces 6.0 and pretty-faces 3.4.1 with the matching version rewrite servlet to use Maven. The EAR consists of a couple library jars, a WAR and an EJB. This EAR also is built to run on WAS. At this point the maven build works as expected and the resulting EAR contains the same structure as it did previously. The WAR is generated with all the pretty-faces and rewrite jars as expecting with nothing additional in the WEB-INF/lib directory. The application does deploy but as soon as you try and hit the login page we get a class def error:

    0000009d PrimeExceptio E org/ocpsoft/urlbuilder/util/Decoder
    java.lang.NoClassDefFoundError: org/ocpsoft/urlbuilder/util/Decoder

    Has anyone experienced this issue or have any ideas on what could be causing this? I am having an issue finding the cause as the jars are in the correct directory and everything is built the same way it was prior to the conversion to use Maven as a build tool.

    #27771

    todw25
    Participant

    This can be closed the issue is resolved

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.