Re: Migration from mojarra 2.0.2 to 2.0.4 generate exception !!!

Splash Forums PrettyFaces Users Migration from mojarra 2.0.2 to 2.0.4 generate exception !!! Re: Migration from mojarra 2.0.2 to 2.0.4 generate exception !!!

#20654

Using RichFaces 3.3.3 together with JSF 2.0 is problematic because RichFaces 3.3.3 requires to manually add the “old” Facelets JAR and disabling the Facelets support provided by JSF 2.0.

See this wiki page for details:

http://community.jboss.org/wiki/RichFaces333andJSF20

There is also a “known problem” with PrettyFaces for JSF 2.0 if used together with the old Facelets implementation (like RichFaces 3.3.3 requires it) as the old Facelets implementation does not parse .taglib.xml files correctly (due to namespace issues).

See this forum post for details:

http://ocpsoft.com/support/topic/strange-exception

I personally don’t think that it is a good idea to use RichFaces 3.3.3 together with JSF 2.0 as it is causing a lot of trouble.

If you have a working configuration with Mojarra 2.0.2 then better keep it! :-)