Re: Java 5 compatibility

Splash Forums PrettyFaces Users Java 5 compatibility Re: Java 5 compatibility

#20185

Hey Tim,

unfortunately the ServiceLoader is currently required, because it is used heavily for our annotation support. You could try to disable annotation support by setting this configuration parameter in web.xml:

<context-param>
<param-name>com.ocpsoft.pretty.BASE_PACKAGES</param-name>
<param-value>none</param-value>
</context-param>