Upgraded to 3.3.2 from 3.3.0; Failed to load configuration

Splash Forums Rewrite Users Upgraded to 3.3.2 from 3.3.0; Failed to load configuration

This topic contains 1 reply, has 1 voice, and was last updated by  clemmonsm 5 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18095

    clemmonsm
    Participant

    Getting the following after upgrading to 3.3.2.

    <Nov 14, 2011 3:23:08 PM EST> <Error> <HTTP> <BEA-101165> <Could not load user defined filter in web.xml: com.ocpsoft.pretty.PrettyFilter.

    com.ocpsoft.pretty.PrettyException: Failed to load configuration.

    at com.ocpsoft.pretty.faces.config.PrettyConfigurator.configure(PrettyConfigurator.java:90)

    at com.ocpsoft.pretty.PrettyFilter.init(PrettyFilter.java:305)

    at weblogic.servlet.internal.FilterManager$FilterInitAction.run(FilterManager.java:332)

    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

    at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

    Truncated. see log file for complete stacktrace

    Caused By: java.lang.NullPointerException

    at com.ocpsoft.pretty.faces.config.annotation.WebClassesFinder.processDirectory(WebClassesFinder.java:110)

    at com.ocpsoft.pretty.faces.config.annotation.WebClassesFinder.processDirectory(WebClassesFinder.java:183)

    at com.ocpsoft.pretty.faces.config.annotation.WebClassesFinder.processDirectory(WebClassesFinder.java:183)

    at com.ocpsoft.pretty.faces.config.annotation.WebClassesFinder.processDirectory(WebClassesFinder.java:183)

    at com.ocpsoft.pretty.faces.config.annotation.WebClassesFinder.processDirectory(WebClassesFinder.java:183)

    Truncated. see log file for complete stacktrace

    >

    Changed the pretty-config.xml header to match the new version:

    <pretty-config xmlns=”http://ocpsoft.com/prettyfaces/3.3.2&#8243;

    xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance&#8221;

    xsi:schemaLocation=”http://ocpsoft.com/prettyfaces/3.3.2

    http://ocpsoft.com/xml/ns/prettyfaces/ocpsoft-pretty-faces-3.3.2.xsd“>

    I continue to receive the above error after reverting back to 3.3.0. If anyone has insight it would be much appreciated.

    #21695

    clemmonsm
    Participant

    It looks like I made a mistake and posted this in the Rewrite forum rather than the PrettyFaces forum. I will re-post there. Please delete this thread. Thanks.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.