There are something wrong with after version 1.4 rewrite.

Splash Forums Rewrite Users There are something wrong with after version 1.4 rewrite.

This topic contains 3 replies, has 2 voices, and was last updated by  Lincoln Baxter III 5 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18328

    dolphincn
    Participant

    older version rule is:

    .addRule(

    Join.path(“/manager/test/{testBean.type}.xhtml”)

    .when(Path.matches(“^/manager/test/(menu|product|article)\.xhtml$”))

    .to(“/manager/manager/test/test_list.xhtml”)

    )

    ths jsf web page form action is :

    <form id=”test_list_panel” name=”test_list_panel” method=”post” action=”/manager/manager/test/test_list.xhtml” enctype=”application/x-www-form-urlencoded”>

    new version rule is:

    .addRule(

    Join.path(“/manager/test/{testBean.type}.xhtml”)

    .where(“testBean.type”).matches(“(menu|product|article)”)

    .to(“/manager/manager/test/test_list.xhtml”)

    )

    ths jsf web page form action is :

    <form id=”test_list_panel” name=”test_list_panel” method=”post” action=”/manager/test/test_list.xhtml” enctype=”application/x-www-form-urlencoded”>

    use older version rewriter ,form action is right,

    but changed to new version, form action is wrong.

    there are no rule or action navigate to “/manager/test/test_list.xhtml”.

    I couldn’t found where was wrong.

    #22485

    Am I correct in understanding that you want /manager/manager/ duplicated in the URL?

    I’m not exactly sure why this would have changed between versions. Any chance you could upload a sample webapp that reproduces this issue?

    If this is a bug, I’d love to fix this for you.

    Thanks~!

    Lincoln

    #22486

    dolphincn
    Participant

    I have tried to find what’s wrong, but my knowlege was limited of jsf and rewriter.

    I update rewriter to version 1.5 or later. some JSF page ajax run well , but some jsf page ajax could not run, finally I found the page’s form action is wrong.

    when I change rewriter back to older version with same web application with nothing changed, the form action is right, the jsf page ajax run well.

    I could not find what’s wrong. maybe I will found it later.

    #22487

    If you attach an application that reproduces this, I’ll be glad to look at it for you.

    Just let me know how to reproduce the problem, in as much detail as possible.

    ~Lincoln

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.