Strange behaviour with same 'pattern' and 'view-id' prefix

Splash Forums PrettyFaces Users Strange behaviour with same 'pattern' and 'view-id' prefix

This topic contains 3 replies, has 2 voices, and was last updated by  bhl 5 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18192

    bhl
    Participant

    Hello,

    I’m trying to use the following mapping:

    pretty-config.xml

    <url-mapping id="mockAnalyzeCase">
    <pattern value="/mock/#{iid}"/>
    <view-id>/mock/caseAnalysis.seam</view-id>
    <action phaseId="RENDER_RESPONSE">#{mockAnalyzeCase.loadData}</action>
    </url-mapping>

    MockAnalyzeCaseBean:

    @RequestParameter("iid")

    private Long lid;

    I am getting java.lang.NumberFormatException: For input string: “caseAnalysis.seam”

    If I change view-id to “<view-id>/mocks/caseAnalysis.seam</view-id>” or some prefix different from pattern, everything works fine.

    JSF 1.2

    PrettyFaces 3.3.2

    Seam 2.2.2

    Spring Security

    WebSphere 6.1

    web.xml filters:

    <filter>
    <filter-name>PrettyFilter</filter-name>
    <filter-class>com.ocpsoft.pretty.PrettyFilter</filter-class>
    </filter>
    <filter-mapping>
    <filter-name>PrettyFilter</filter-name>
    <url-pattern>/*</url-pattern>
    <dispatcher>REQUEST</dispatcher>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>ERROR</dispatcher>
    </filter-mapping>

    <filter>
    <display-name>RichFaces Filter</display-name>
    <filter-name>richfaces</filter-name>
    <filter-class>org.ajax4jsf.Filter</filter-class>
    <init-param>
    <param-name>createTempFiles</param-name>
    <param-value>false</param-value>
    </init-param>

    <init-param>
    <param-name>maxRequestSize</param-name>
    <param-value>2100000</param-value>
    </init-param>

    <init-param>
    <param-name>forceparser</param-name>
    <param-value>false</param-value>
    </init-param>

    <init-param>
    <param-name>enable-cache</param-name>
    <param-value>true</param-value>
    </init-param>
    </filter>
    <filter-mapping>
    <filter-name>richfaces</filter-name>
    <servlet-name>FacesServlet</servlet-name>
    <dispatcher>REQUEST</dispatcher>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>INCLUDE</dispatcher>
    </filter-mapping>

    <filter>
    <filter-name>SeamFilter</filter-name>
    <filter-class>org.jboss.seam.servlet.SeamFilter</filter-class>
    <init-param>
    <param-name>createTempFiles</param-name>
    <param-value>false</param-value>
    </init-param>
    <init-param>
    <param-name>maxRequestSize</param-name>
    <param-value>2000000</param-value>
    </init-param>
    </filter>
    <filter-mapping>
    <filter-name>SeamFilter</filter-name>
    <url-pattern>/*</url-pattern>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>REQUEST</dispatcher>
    <dispatcher>ERROR</dispatcher>
    </filter-mapping>

    <filter>
    <filter-name>springSecurityFilterChain</filter-name>
    <filter-class>org.springframework.web.filter.DelegatingFilterProxy</filter-class>
    </filter>
    <filter-mapping>
    <filter-name>springSecurityFilterChain</filter-name>
    <servlet-name>FacesServlet</servlet-name>
    <url-pattern>/*</url-pattern>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>REQUEST</dispatcher>
    </filter-mapping>

    Does anyone have a suggestion? It would be greatly appreciated. :)

    Thank you!

    Bruno

    #22213

    bhl
    Participant
    #22214

    Hi,

    could you try PrettyFaces 3.3.3 which was just released yesterday? This looks like a bug we recently fixed.

    Thanks

    Christian

    #22215

    bhl
    Participant

    It is working perfectly now!

    I’ve just checked PrettyFaces homepage and now it is announcing this version as stable.

    Thanks a lot, Christian!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.