Reference com.ocpsoft.pretty.PrettyFilter not found

Splash Forums PrettyFaces Users Reference com.ocpsoft.pretty.PrettyFilter not found

This topic contains 1 reply, has 1 voice, and was last updated by  clemmonsm 5 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #18094

    clemmonsm
    Participant

    I upgraded to 3.3.2 from 3.3.0 and I am now getting the above reference not found warning in web.xml and related errors on compile in my project classes.

    My web.xml contains the following at the top of each list respectively:

    <filter>
    <filter-name>Pretty Filter</filter-name>
    <filter-class>com.ocpsoft.pretty.PrettyFilter</filter-class>
    </filter>
    <filter>
    <filter-mapping>
    <filter-name>Pretty Filter</filter-name>
    <url-pattern>/*</url-pattern>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>REQUEST</dispatcher>
    <dispatcher>ERROR</dispatcher>
    </filter-mapping>

    and my pretty-config.xml contains the following:

    <pretty-config xmlns="http://ocpsoft.com/prettyfaces/3.3.2"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://ocpsoft.com/prettyfaces/3.3.2
    http://ocpsoft.com/xml/ns/prettyfaces/ocpsoft-pretty-faces-3.3.2.xsd">
    ...
    </pretty-config>

    A project clean and rebuild does not resolve the errors. I have to be missing something simple…thoughts?

    #21694

    clemmonsm
    Participant

    Resolved, had to re-add the folder to the classpath.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.