PrettyFaces 3.3.1 for JSF 1.2 introduces Servlet 3.0 dependency

Splash Forums PrettyFaces Users PrettyFaces 3.3.1 for JSF 1.2 introduces Servlet 3.0 dependency

This topic contains 3 replies, has 2 voices, and was last updated by  tomkur 5 years, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18074

    tomkur
    Participant

    Hello,

    I don’t know if this was done on purpose, but PrettyConfigReloader.onNewRequest method uses ServletRequest.getServletContext method, which was introduced to Servlet 3.0 API and is not available in Servlet 2.5 API. I expect PrettyFaces 3.3.1 for JSF 1.2 to work with Servlet 2.5 API.

    (sorry for not including my configuration, but I am Pretty sure it is not relevant in this case)

    Best regards!

    #21640

    Doh! Yeah, you are completely correct. That was my fault and not intended. We are compiling against the Servlet 3.0 API so I didn’t notice it. Damn!

    #21641

    I just committed a fix for this issue. Could you perhaps give 3.3.2-SNAPSHOT a try? I think everything should work fine there.

    #21642

    tomkur
    Participant

    I will, but next week. Thanks

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.